Squid configuration directive ie_refresh

Available in: 4   3.5   3.4   3.3   3.2   2.7   3.1   3.0   2.6  

For older versions than 3.3 see the linked pages above

Configuration Details:

Option Name:ie_refresh
Replaces:
Requires:
Default Value:ie_refresh off
Suggested Config:

	Microsoft Internet Explorer up until version 5.5 Service
	Pack 1 has an issue with transparent proxies, wherein it
	is impossible to force a refresh.  Turning this on provides
	a partial fix to the problem, by causing all IMS-REFRESH
	requests from older IE versions to check the origin server
	for fresh content.  This reduces hit ratio by some amount
	(~10% in my experience), but allows users to actually get
	fresh content when they want it.  Note because Squid
	cannot tell if the user is using 5.5 or 5.5SP1, the behavior
	of 5.5 is unchanged from old versions of Squid (i.e. a
	forced refresh is impossible).  Newer versions of IE will,
	hopefully, continue to have the new behavior and will be
	handled based on that assumption.  This option defaults to
	the old Squid behavior, which is better for hit ratios but
	worse for clients using IE, if they need to be able to
	force fresh content.

 

Back

 

Introduction

Documentation

Support

Miscellaneous

Web Site Translations

Mirrors