Squid configuration directive upgrade_http0.9

Available in: 2.7  

Configuration Details:

Option Name:upgrade_http0.9
Replaces:
Requires:
Default Value:none
Suggested Config:
# Don't upgrade ShoutCast responses to HTTP
acl shoutcast rep_header X-HTTP09-First-Line ^ICY.[0-9]
upgrade_http0.9 deny shoutcast

	This access list controls when HTTP/0.9 responses is upgraded
	to our current HTTP version. The default is to always upgrade.

	Some applications expect to be able to respond with non-HTTP
	responses and clients gets confused if the response is upgraded.
	For example SHOUTcast servers used for mp3 streaming.

	To enable some flexibility in detection of such applications
	the first line of the response is available in the internal header
	X-HTTP09-First-Line for use in the rep_header acl.


 

Back

Search

 

Introduction

Documentation

Support

Miscellaneous

Web Site Translations

Mirrors