Squid's snmp is broken??

From: Maxim Zimovets <Zimovets@dont-contact.us>
Date: Thu, 24 Dec 1998 09:21:20 +0500

Hi squid's snmp guru,

I've sent this letter for squid's mailing list, but still no any reply.
I suppose squid's snmp is broken. Because of it tkined's not working completely.
(though in faq squid developpers wrote that tkined worked with squid's snmp)
Here's my letter:

I use squid2.1-PATCH2+ fix on Slakcware Linux 3.3 with libc5.4.46.
Have a look on following listing (made with tcpdump):
1.I issuedfollowing command to fetch some variables from snmp-agent
(for linux - 3.5)
      snmpwalk some2 some3 system (get next request method)
12:13:50.290868 some1.1819 > some2.snmp: GetNextRequest(25) system
12:13:50.290868 some2.snmp > some1.1819: GetResponse(116) system.sysDescr.0="Linux version
2.0.34 #2 Tue Jul 28 18:50:41 ESD 1998"
12:13:50.310868 some1.1819 > some2.snmp: GetNextRequest(27) system.sysDescr.0
12:13:50.310868 some2.snmp > some1.1819: GetResponse(38) system.sysObjectID.0=E:1575.1.5
12:13:50.330868 some1.1819 > some2.snmp: GetNextRequest(27) system.sysObjectID.0
12:13:50.330868 some2.snmp > some1.1819: GetResponse(32) system.sysUpTime.0=1287327
It's ok.

2. Almost the same command for squid snmp-agent
      snmpwalk some4 some3 . (the same get next request method)
12:10:33.540868 some1.1793 > some4.snmp: GetNextRequest(28) E:3495.1.1
12:10:33.540868 some4.snmp > some1.ru.1793: GetResponse(34) E:3495.1.1.1=86016
12:10:33.550868 some1.1793 > some4.snmp: GetNextRequest(29) E:3495.1.1.1
12:10:33.550868 some4.snmp > some1.1793: GetResponse(33) E:3495.1.1.2=515
As You can see in OID there's no trailing 0 to identify particular instance
of an object. It's rather strange, isn't it?

Because of it tkined can't fetch any variables (tkined uses as far as
I've seen get request method). Request for . subtree:
12:19:05.440868 some1.1865 > some4.snmp: GetRequest(65) E:3495. E:3495.
12:19:05.440868 some4.snmp > some1.1865: GetResponse(73) noSuchName@1 E:3495.
12:19:05.440868 some1.1865 > some4.snmp: GetRequest(31) E:3495.
12:19:05.450868 some4.snmp > some1.1865: GetResponse(35) noSuchName@1 E:3495.

How to solve it?

Another problem with obtaining clients' results through snmp. I can see
users in cache manager (cache client list), but with snmp I can only see
one user (but correct results). Moreover it doesn't matter who was the
first client after cache's restart. I just see one particular user.
What about this problem?

Wait for suggestions and comments

Maxim Zimovets
System Administrator
Received on Wed Dec 23 1998 - 20:29:04 MST

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 17:22:06 MST