Intialization Of MRTG script for squid

From: Kashan Sadiq <>
Date: Wed, 23 Feb 2000 22:47:03 -0800

Hi Everybody,

I downloaded the script mrtgPerlScript from
irccahe written by Kostas Anagnostakis. I m
facing problem in its execution.
Now if anybody have worked with that please help
me in detail. Now actually we use "cfgmaker"
script to make an cfg file
and run it with "mrtg". What I suppose to do with
this script. While everytime I try to execute it
by the following command it gives me an error
which is given after coammand.

The commands which I tried are

/usr/bin/perl5 mrtgperlscript public@hostname >

THe error is
thisisprompt# /usr/bin/perl5
ERROR: Can't find location of mrtg executable
BEGIN failed--compilation aborted at
line 58.
when i use this command

/usr/bin/perl5 mrtg mrtgperlscript
public@hostname > cfgfile

it gives me error in cfgfile which is

"ERROR: unable to open config file:

Usage: mrtg <config-file>

mrtg: Multi Router Traffic Grapher.

If you want to know more about this tool, you
might want
to read the docs. They came together with mrtg!

g.html "


Now if anybody can figure out, what is the
mistake I m doing. Tell me frankly wether after
seeing it he considers me a layman.
I don't mind :)

Thanks for your help

Kashan Sadiq
Received on Wed Feb 23 2000 - 10:48:27 MST

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 17:22:10 MST