MRTG and Squid (problem solved!)

From: Nuno Guarda <>
Date: Tue, 23 May 2000 09:46:49 +0100

Hi all.

The purpose of this message is to give some help to those that have or will
have the same problem I've had.

After I've posting a message with subject "MRTG and Squid (PROBLEM
SOLVED)", I've received and replyed a lot of email messages asking for the
solution, so I decided to post to this list the problem and the solution .

I have the latest version of MRTG (version 2.8.11) and I'm using Squid
version 2.2.STABLE5.

I've compiled and installed Squid with ./configure --enable-snmp and i'm
already using MRTG to collect some information in some Cisco routers I have.

I've configured squid.conf to act allow SNMP (the message "Accepting SNMP
messages on port 3401" appears in my cache.log file) but, using your
configuration file available at, I
get multiple errors like:
SNMPGET: Failed to reach target:
"cacheServerRequests&cacheServerRequests:public@localhost:3401". I tried
multiple times!
Unknown SNMP var cacheSysPageFaults
Unknown SNMP var cacheSysPageFaults

My squid.conf has the following lines:
        acl snmppublic snmp_community public
        snmp_port 3401
        snmp_access allow snmppublic localhost
        snmp_access allow snmppublic cache-mgr (where cache-mgr is an ACL
identifying the IP address of the Squid host)
        snmp_access deny all


My problem was that I was not including a line like:
  LoadMIBs: /path/to/mib.txt
in the MRTG configuration file. This mib.txt is distributed with Squid and
placed, normally, in the same place where squid.conf is.

Help about using the command LoadMIBs is available in the MRTG manual.

After that, the errors I was getting disapear (almost all of them, I think
I've deleted some lines).

Best regards,

Received on Tue May 23 2000 - 02:47:41 MDT

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 17:22:11 MST