Re: HEAD compile error on Alpha Linux and Compaq C Compiler - SOLVED - [PATCH]

From: Guido Serassio <>
Date: Sat, 29 Dec 2001 10:29:20 +0100

Hi Henrik,

Il 02.39 29/12/2001 Henrik Nordstrom ha scritto:
> >
> > OK, but the not working include file is a gcc include file used from ccc,
> > so, I think that ask to the gcc team to change this file can be ...
> > blasphemous .....
>It is not the GCC team you have to ask. /usr/include/byteswap.h is a glibc
>header, not a GCC header. The GCC headers are properly separated from system
>headers in /usr/lib/gcc-lib/..../include/
>/usr/include/ headers should be pretty much compiler neutral (won't in a
>number of years, but should..)

I don't know this.

But there is something of strange that I don't understand:

Looking on config.log file I have found:

configure:5123: checking byteswap.h usability
configure:5132: ccc -c -s conftest.c >&5
configure:5135: $? = 0
configure:5138: test -s conftest.o
configure:5141: $? = 0
configure:5150: result: yes
configure:5154: checking byteswap.h presence
configure:5161: ccc -E conftest.c
configure:5167: $? = 0
configure:5185: result: yes
configure:5203: checking for byteswap.h
configure:5210: result: yes

So, configure seems to have tried to use successfully byteswap.h.
After this, I have tried to compile the following test file:

#include <stdio.h>
#include <byteswap.h>

void main(void)
         printf("Hello World !!!\n");

It compiles fine. What is wrong in my Alpha ?


Serassio Guido
Via Albenga, 11/4 10134 - Torino - ITALY
Received on Sat Dec 29 2001 - 02:29:26 MST

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:14:42 MST