squid (1.1.14) on DEC ALPHA OSF/1

From: Alan J. Flavell <flavell@dont-contact.us>
Date: Sat, 11 Oct 1997 20:40:44 +0100 (BST)

Quick and sketchy report of problems and progress. Sorry, I don't
have time to document this in great detail.

I decided to go for the "current stable release" 1.1.14.

The ./configure ... went without obvious complaints.

First evidence of problems is below "Making all in src...":

gcc -g -O2 -Wall -I. -I../include -I./../include -c acl.c
In file included from squid.h:272,
                 from acl.c:31:
cache_cf.h:124: parse error before `regex_t'
cache_cf.h:124: warning: no semicolon at end of struct or union
cache_cf.h:126: parse error before `}'

and it just goes downhill from there.

OS is:

> uname -a
OSF1 .. V3.2 214 alpha

and it's using gcc:

> gcc -v
Reading specs from
gcc version 2.7.0

I thought maybe gcc was the problem, so I went and installed
a recent version, specifically

Installation of this version of gcc seemed to go OK.

Then I went back to building squid.

Tried ./configure ... , and make all again

This time it failed almost immediately.

So I tried various combinations of make clean and ./configure

Still no improvement.

Finally in desperation I deleted the entire subdirectory tree,
re-un-tarred the tarfile, and did the ./configure from scratch.

Then the make finally ran to completion, and squid seems to be working.

Hope that helps someone else to get the software built.

- - -

As I mentioned to Martin H, our cache runs inside of an address domain
that has access to remote web pages that are access-controlled by calling
address. That makes it difficult for our cache to participate in bothway
cache partnerships, but I still think that caching is useful (indeed,
we've been doing it, with a harvest cache, for some years now already).

Also had a bit of a problem with the ownerships of the various parts of
the filetree. Unlike, say, Apache, it doesn't seem to be able to open the
files with root privs before switching to its running UID/GID. At the
moment I'm starting it up as a normal user and have chowned the relevant
parts of the file hierarchy to that user. The Apache hints recommend
having as few files as possible owned by the "nobody" user, and that
dissuades me from running squid as "nobody" if it means the files have to
be chowned to "nobody" (and thus be potentially at risk from any CGI
script that the HTTPD may be running!).

Just random thoughts. No doubt these issues have been discussed
before, but a quick scan of the mail archive didn't show much.

Received on Sat Oct 11 1997 - 12:49:52 MDT

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:37:16 MST