RE: SOLVED: Error with squid log analysis scripts

From: Larmour, Jonathan <>
Date: Fri, 14 Nov 1997 17:45:10 -0000

Hash: SHA1

Just a little follow-up on this even though its off-topic. It
transpires that suidperl for 5.003 has a security flaw. 5.004 is
unaffected, so that's another very good reason to upgrade to 5.004.

Jonathan L.
Origin, 323 Cambridge Science Park,Cambridge,UK. Tel:+44 (1223)
 ---[ It is impossible to enjoy idling thoroughly unless one has ]---
 ------------[ plenty of work to do - Jerome K. Jerome ]-------------
Fight spam! These opinions are all my fault

- ----------
From: Armistead, Jason
Sent: 10 November 1997 00:37
To: 'Squid-Users'
Subject: SOLVED: Error with squid log analysis scripts

Hi all Squidders

I just found the solution to my own problem.

Apparently there was some major enhancement work done to Perl, in the
5.004.01 version, specifically related to the problem of "attempt to
free non-existent shared string .....". So, when I downloaded,
and installed the latest Perl version 5.004.01, the problem messages
went away. Perhaps people using earlier versions of Perl (my problem
was originally with the 5.003.01 version), which didn't have such
functionality never even saw these messages. I'm assuming Duane W
in this category, because I couldn't imagine him not debugging !!!

So, moral of the story - get Perl 5.004.01 and skip 5.003.01 !!!

Maybe this is worth a comment in the FAQ somewhere ?????? It sure
wasted me a lot of time.



>From: Armistead, Jason
>Sent: Monday, 3 November 1997 12:54
>To: 'Squid-Users'
>Subject: Error with squid log analysis scripts
>I'm using the following squid log analysis scripts and getting some
>that, although they don't affect the actual functionality, they do
affect the
>results on STDERR (my terminal)
>The scripts are exactly as from the "Log Analysis Scripts" page at
>Here is my Perl information:
>Summary of my perl5 (5.0 patchlevel 3 subversion 1) configuration:
> Platform:
> osname=solaris, osvers=2.5.1, archname=sun4-solaris
> uname='sunos ozm10 5.5.1 generic_103640-03 sun4u sparc
sunw,ultra-1 '
> hint=recommended, useposix=true, d_sigaction=define
> Compiler:
> cc='gcc', optimize='-O', gccversion=2.7.2
> cppflags=''
> ccflags =''
> stdchar='unsigned char', d_stdstdio=define, usevfork=false
> voidflags=15, castflags=0, d_casti32=define, d_castneg=define
> intsize=4, alignbytes=8, usemymalloc=y, randbits=15
> Linker and Libraries:
> ld='gcc', ldflags =''
> libpth=/lib /usr/lib /usr/ccs/lib
> libs=-lsocket -lnsl -ldl -lm -lc -lcrypt
> libc=/lib/, so=so
> Dynamic Linking:
> dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=, ccdlflags=' '
> cccdlflags='-fpic', lddlflags='-G'
>Characteristics of this binary (from libperl):
> Built under solaris
> Compiled at Jul 8 1997 15:07:31
> @INC:
> /usr/local/lib/perl5/sun4-solaris/5.00301
> /usr/local/lib/perl5
> /usr/local/lib/perl5/site_perl/sun4-solaris
> /usr/local/lib/perl5/site_perl
> .
>And here is the error message:
>Attempt to free non-existent shared string at ./
line 131,
><> c
>hunk 5319.
>Anyone got a solution to this one ? My Perl skills aren't the
greatest I'm
>Jason Armistead
Version: PGP for Personal Privacy 5.0
Charset: noconv

Received on Fri Nov 14 1997 - 09:55:14 MST

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:37:33 MST