Re: Understanding DNS service

From: Andre Coetzee <>
Date: Wed, 24 Dec 1997 10:17:07 -0800

When I use named -r, it solves most of the problems - there are no
unnecessary delays;
all my local machines can see each other; and squid delivers items that
have been
cached. Only problem now is, if its not in the cache, then I still get a
"DNS error - hostname
does not exist" report from squid (obviously I think, because of the -r
option in named).

I am also using ipfwadm, so I tried the following test:

Enable tcp.domain requests in diald standard.filter
Configure squid to bind to the same ip address that diald uses for the
local side of the link.
        (tcp_outgoing and udp_outgoing in squid.conf)
Disable all domain packets from the local machine in ipfwadm, except
from the designated ip address.

After I kill -HUP everything, it still doesn't dial, and behaves exactly
as if I had not done the
steps mentioned in the above test (behavior described in the first

Perhaps I have denied a bit too much with ipfwadm, I think I to allow my
local network to send DNS
messages to my nameserver, but not directly to the ip addres I assigned
to diald.

I admit my understanding of all this is rather basic, but I have read
through the relevant HOWTOS and man pages, and they made sense as usual,
and normally everything works fine when you follow the instructions.

I think I am on the verge of a breakthrough.
Received on Wed Dec 24 1997 - 00:20:46 MST

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:38:02 MST