Re: possible Solaris oddity ?

From: Duane Wessels <>
Date: Thu, 05 Feb 1998 10:52:50 -0700

Martin Hamilton writes:

>Here's something weird which has been happening on one of the JANET
>top level caches. From time to time Squid tries to create a new cache
>object, but we end up with a root owned file in the relevant cache
>swap directory (we run Squid as a special user) and Squid barfs.
>[As a meta comment I think it might be better if Squid tried an
>alternative name, and/or tried to unlink or rename an existing file
>which it couldn't open. Looks like (at the moment) we just try and
>open the swap file for writing and bomb out if this fails.]
>FWIW, this is on an Ultra 1 with :-
> Solaris 2.6
> recommended patches
>Anyone else experiencing this ? I was wondering if the solar flares
>were especially bad over here just now or something... :-)
>I should say that we've just upgraded to 1.NOVM.20 to see if this
>makes any difference. My intuition is that we're simply stressing
>Solaris too much, and it can't cope. It would be interesting to hear
>if anyone else has had similiar experiences.

There have been similar reports in the past. I don't have them
handy, but I doubt its specific to solaris-2.6 (but maybe specific
to solaris).

Do you start squid as root and use the 'cache_effective_user' option?

Duane W.
Received on Thu Feb 05 1998 - 09:57:41 MST

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:38:47 MST