Re: Hrm.. weird error

From: David Luyer <>
Date: Tue, 21 Apr 1998 16:04:31 +0800

> The message "FATAL: malloc: Unable to allocate 4096 blocks of 1
> bytes!"

The message I saw on the list was the standard one I've included below,
it was the one in the message I responded to. This is usually accompanied
by "Hello. I am new to Unix and to Squid. I am running Squid on FreeBSD/BSDOS
and it gives me this error. Tell me what is wrong (error: some malloc error)."

> On a Pentium Pro with 256 mb of ram using FreeBSD 2.2.5 i was getting the
> above message every 5 to 10 mins..

> On FreeBSD, the above problem can be duplicated by compiling a kernel with
> options SYSVSHM

Did you

* include the kernel options as specified in the FreeBSD section of the
  FAQ article I pointed to earlier
* check with limit/ulimit that everything is also unlimited at the shell
* check the free swapspace


> however neither of the above possible causes were
> the reason behind it. So despite reading the FAQ my problem was still not
> answered.

Are you sure? That would really surprise me.

> If the FAQ does not answer our question, are we supposed to keep our mouth
> shut to avoid irritating someone who does not feel like answering a
> question

No - but the question as phrased looked like an exact "this person hasn't
read the FAQ". If they had, then they should have said "I've checked my
kernel options, recompiled, checked my limits and STILL get this error".
Then people would take more notice.

> > > Apr 21 04:13:07 proxy Apr 21 04:13:07squid[: xmalloc: Unable to allocate
> > > 4096 bytes!

Received on Tue Apr 21 1998 - 01:06:23 MDT

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:39:47 MST