FATAL: storeUnlockObject: unlocked with pending clients

From: <squid-users-list@dont-contact.us>
Date: 15 Jul 1998 13:56:13 +0100

Running 1.NOVM.21+retry under recent FreeBSD 2.2.6-STABLE.
I'm doing some testing of squid, because my manager wants me to prove
that it is better than Novell's FastCache on the same hardware.
As there don't seem to be any free cache testing tools out there,
I've been knocked up some test programs to run on a client machine.
  In one test I ran 400 processes, which each tried to make a
connection to squid. It died with the error:

FATAL: storeUnlockObject: unlocked with pending clients

What does this mean? It never fails to die when I run my test script.
Always with that error.
Don't let FastCache take over, at our site :)

Mark Powell - System Administrator (UNIX) - Clifford Whitworth Building
A.I.S., University of Salford, Salford, Manchester, UK.
Tel:	+44 161 295 5936	Fax:	+44 161 295 5888
Email:	M.S.Powell@ais.salfrd.ac.uk	finger mark@ucsalf.ac.uk (for PGP key)
NO SPAM please: Spell salford correctly to reply to me.
Received on Wed Jul 15 1998 - 05:57:37 MDT

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:41:07 MST