stalled transfers (performance problem?)

From: Barrie Spence <>
Date: Thu, 6 Aug 1998 23:40:53 +0100 (BST)

I've been using squid-1.1.x at home under Linux for a long time
now and have always attributed slow and stalled transfers as
external to my local machine. I've just started to play with
a squid cache at work (HP-UX 10.20) and I often experience
"stalled" transfers (typically a page is partially displayed
and netscape reports a decreasing byte transfer rate). Cancelling
the load and initiating a reload sometimes fixes the problem, but
not always.

In both cases, the main browser client is local to the cache
machine, with light access from one or two other clients. In
either case, I don't see the hardware being the problem relative
to the network link (and the caches haven't been running long
enough to see any memory usage problems).

While the transfer is stalled, the cache appears to be sluggish/
unresponsive to other clients.

At work, I've tried both 1.1.22 and 1.2.beta23 (both built with
the HP ANSI C compiler - the same behaviour is also apparent with

I don't have anything fancy in my configuration and I've tried it
with and without autoproxy configuration

Any suggestions?


Barrie Spence			Sanity Clause? There is no Sanity Clause
Home:		Telephone +44 1506 442304
Play:			Telephone +44 131 331 7103
Received on Thu Aug 06 1998 - 15:43:21 MDT

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:41:27 MST