Re: Linux and beta24 shutdown signals still not working

From: Miquel van Smoorenburg <>
Date: 26 Aug 1998 16:26:49 +0200

In article <007f01bdd0bd$68ac7190$>,
Andrew Hall <> wrote:
>I have just upgraded to 1.2beta24+diffs, and have recompiled with =
>threads enabled. Unfortunately the logrotate signal (-USR1) under Linux =
>is still not working ( or at least I can't get it to work). I was told =
>that it should now work in beta24 but I'm wondering whether I need to =
>enable the "kill-parent-process-hack" on compile? What does this do?

If you are using threads, do not use kill -USR1 <squidpid> but instead
use "squid -k rotate". That will send the appropriate signal (which is
not USR1 because that is reserved for the pthreads library under Linux).


 Miquel van Smoorenburg | Our vision is to speed up time,  |   eventually eliminating it.     <*>
The From: and Reply-To: addresses are internal mail2news gateway addresses.
Reply to the list or to (Miquel van Smoorenburg)
Received on Wed Aug 26 1998 - 07:27:38 MDT

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:41:44 MST