Re: 1.2 problems on Solaris v2.5 (ss20)

From: Alex Rousskov <>
Date: Thu, 17 Sep 1998 01:39:08 -0600 (MDT)

On Thu, 17 Sep 1998, Alexander Serkin wrote:

> Unfortunately i had to return to version 1.1.22. The reason is that
> 1.2beta24 sometimes starts to refuse connections to itself. The process
> is still running, but nobody can connect to it.
> It happens after squid encounters some problems with writing to disk. I
> do not remember exactly the error text but it comes from disk.c.
> After that only "kill -9" can stop the process.
> I tried the configuration with two partitions on different disks with
> the sizes of 2Gb and 800 Mb. Used async writes. Listening to tcp ports
> 3128 and 8090.

What patches did you apply to b24 if any?
For how long did Squid run before stalling?
Did you --enable-cache-digests?
By "async writes", do you mean --enable-async-io option?
Have you tried to shutdown squid with "squid -ks"?
When killed with "kill -9" would Squid restart immediately or did you have to
     wait for some time?
What was the CPU utilization of Squid after it stalled?
Any unusual messages in cache.log?
Have you run any recent beta versions before?

Just trying to get some more info...


Received on Thu Sep 17 1998 - 00:41:31 MDT

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:42:03 MST