Re: ICP not working as expected with Squid 2.0.PATCH2

From: as web server manager <>
Date: Wed, 14 Oct 1998 16:55:54 +0100 (BST)

Janos Farkas wrote:
> On 1998-10-14 at 13:07:31, John Line wrote:
> > With cache_peer lines ending " parent 8080 3130", ICP requests do not
> > work as expected (though the same config works with 1.NOVM.22) and instead
> > (with some extra logging enabled) I see e.g.
> >
> > 1998/10/14 12:38:46| neighborsUdpAck: Unexpected ICP_MISS for FC63DC7ADFE328FA18F859B1A47C1974
> Quite a few of use has been bitten by it, check dead_peer_timeout in
> squid.conf. It's defaulting to 10 seconds, meaning if your squid hasn't
> heard of a peer in 10 seconds, it won't use it. For us with very light
> loads, i.e. very few users, so 10 seconds without a query is quite a
> common, it means squid will always try to go direct for the first query
> after a longer pause. You might want to up it for maybe a hour, or so,
> it worked wonders for me.. Still, I don't quite like it this way :)

Thank you - that fixed it. I probably only did one test each time before
changing the configuration to try and fix the problem... (and it was a test
server, not live, so no requests from anyone other than me).

                                John Line

University of Cambridge WWW manager account (usually John Line)
Send general WWW-related enquiries to
Received on Wed Oct 14 1998 - 09:49:00 MDT

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:42:29 MST