Re: 2.2pre1 - RunCache...and Squid stops answering?

From: Duane Wessels <>
Date: Fri, 29 Jan 1999 09:33:40 -0700

Chris Cappuccio writes:

>Hi folks,
>I'm running Squid 2.2PRE1 on an OpenBSD 2.4 machine...
>It has been running 2.1p2 for over a month without any problems.
>When I moved up to 2.2pre1, the RunCache script stopped working...It keeps
>running squid, thinking that it has died, but in fact just ends up running
>five copies of squid and four of them die off. So, I run squid directly
>because it is supposed to behave more like a daemon.

You should still be able to use RunCache if you want to. You'd
have to add -N option to squid.

>After ten or so hours of operation with small/moderate load, squid stops
>answering on port 3128. If I telnet to the port, I don't get connection
>refused, it just sits there, as if the cache server is down.
>Squid is still running, however, and kill -HUP `cat` seems to fix
>this behavior. Any ideas what I should do? I tried increasing the number of
>'dnsserver' processes but the way I understand it if it was too small that
>wouldn't cause this ???

It could be caused if Squid is leaking (forgetting to close) file
descriptors. You can monitor the filedescriptor usage from
the cache manager menus. For example:

        client mgr:filedescriptors | less

Duane W.
Received on Fri Jan 29 1999 - 09:29:26 MST

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:44:11 MST