dnserver problems

From: William H. Gilmore <whgi@dont-contact.us>
Date: Mon, 26 Apr 1999 16:43:56 -0600


OS: RedHat 5.2, Kernel 2.0.36-0.7

I have been using squid succesfully for about a year now. Over the last
week, while I was out of town actually, something happened and squid could
no longer resolve DNS names properly. I suspected that something happened
with my ISP but nslookup tests resolve properly. I changed the order of the
DNS Servers in the /etc/resolv.conf. nslookup still worked fine but squid

When I run dnsserver manually, it works.

        [root@portal squid]# ./dnsserver
        $addr 0

However, when I attempt to connect to http://www.exxon.com, I get the
following errors in the cache.log (debug = 3)

        see squid.001.log

I have tried this with multiple destination hosts and two different browsers
on four different machines. The initial failure occurred when I was running
squid version 1.1.22. Since I had made very few changes from the initial
install from a RedHat RPM, I removed and reinstalled squid version 1.1.22
and the same thing happened. I am currently running
squid-rhcn-2.2.DEVEL4-1. The shipped squid.conf file required some fairly
significant surgery to get it work (primarily in the security areas).
However, by following the FAQ, I got it to replicate the same error as in

The following attachment contains the active (i.e. non-commented) lines in
my squid.conf.

        see squid.conf

Any help that anyone can offer will be greatly appreciated.



Received on Mon Apr 26 1999 - 16:54:33 MDT

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:45:57 MST