[SQU] WCCP and squid / please help me!

From: Justin Kim <hk3183@dont-contact.us>
Date: Tue, 16 Jan 2001 17:15:03 -0700

Hello Gurus out there.
I am about to bang my head on wall.
I tried both gre and ip_wccp modules,
if you could help me, solution or suggestions,
would be appreciated.

Squid box: OS-Mandrake7.2 Linux(kernel 2.2.17)
 using gre module
 ifconfig gre0 netmask
 /sbin/ipchains -A input gre0 -p tcp -d 80 -j REDIRECT 3128

Router: Cisco 7507 - ISO 12.1(2)T
 ip wccp version 1
 ip wccp web-cache
 interface ATM0/0/0.65 multipoint
 description ########
  ip address x.x.46.1
  ip access-group 104 in
  ip wccp web-cache redirect out
  ip pim sparse-dense-mode
  ipx encapsulation ARPA

Squid box is connected to CISCO switch(29xx) and swith is connect to
router. So this is not directly connection

Problem: Router sees squid box(wccp cache),
 but doesn't redirect the gre packet.
 on wccp event log, router sees,
 HERE I AM, I SEE YOU pakets,
 but nothing after that.

 typed client mgr:event
 this is what I got.

HTTP/1.0 404 Not Found
Server: Squid/2.3.STABLE2
Mime-Version: 1.0
Date: Tue, 16 Jan 2001 05:54:33 GMT
Content-Type: text/html
Expires: Tue, 16 Jan 2001 05:54:33 GMT
X-Squid-Error: ERR_INVALID_URL 0
X-Cache: MISS from Alphacentari
Proxy-Connection: close

all the squid log indicating they are running up and fine. No errors
what so ever. I tested with client command locally, and it works great.
It just seems that squid doesn't see Wccp packet (or router doesn't send


Can anybody help me? please?
I tried with squid 2.3.STABLE5 as well, but same result.
I am wondering, if my ipchains config is messed up.
or since my squid box is not directly connect to router,
or gre packet somehow dropped...
please, any help any sugguestion, I'd appreciate it!
thank you.

Justin Kim

To unsubscribe, see http://www.squid-cache.org/mailing-lists.html
Received on Tue Jan 16 2001 - 17:17:29 MST

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:57:28 MST