Re: [SQU] Squid running on Red Hat 6.2 as transparent proxy locks up MSIE 5

From: Henrik Nordstrom <>
Date: Mon, 05 Mar 2001 08:42:38 +0100

Have seen very similar problems with IE, where IE hangs if certain HTTP
header values are received (for example "Age: 0" in combination with
"Cache-Control: max-age=0"). Some of these issues are worked-around in
the current Squid-2.4 sources, and some patches to earlier Squid sources
are available from

A better action is to get the browser fixed. This is a 100% browser bug.

Henrik Nordstrom
Squid hacker
Stuart Parker wrote:
> Hi there,
> We experienced a problem about 4 months ago whereby machines on 2
> seperate networks had a problem connecting to one of our web sites.
> The client machine if it was running Windows 95/98/NT and connecting
> with Internet Explorer would lock up. The cpu would be using 100% of
> the CPU and would not release it until IE was quit. In both cases it
> turned out that both sites had a transparent proxy enabled.
> Fortunately, we were able to communicate this to the network
> administrators of both sites and upgrading/flushing the cache
> appeared to fix the problem in both cases. However, the problem has
> returned on another network and we expect that it will keep occuring,
> so we would like to resolve the issue. The versions of Squid
> previously affected were Squid 2.2Stable3 and 2.4Devel1. The current
> network affected is transparently proxied by a machine running a Dell
> PowerApp.cache which AFAIK runs some version of squid on RH6.2.
> What I'm considering
> 1. In MSIE on the client, turning off "Use HTTP/1.1" in the Internet
> Options stops the lockup from occuring. Obviously we can't tell all
> of our visitors to do this when they visit our site though.
> 2. Upgrading or flushing Squid also fixes the problem (could squid
> somehow simply get corrupted? If so any idea how to prevent it?).
> 3. Red Hat Linux 6.2 appears to be a consistent factor here. In
> section 14.5 of the FAQ I can't find anything specific to RH6.2 but I
> can't shake the feeling there is something here.
> 4. I have read about half-closed connections and how it is poor form,
> but I don't know which clients/servers this affects.
> 5. I read in the archives that squid does not support pipelining and
> does not act as a HTTP 1.1 proxy. I understand that this means that
> squid will chain a couple of requests together using keepalive but
> that's it. Is there any more documentation/notes on this and any
> potential issues it could cause?
> 6. I've tried to downgrade responses via the following line in our
> apache configuration file in the hope that this would force all
> connections into a 1.0 mode, but it didn't work.
> BrowserMatch "MSIE 5" nokeepalive downgrade-1.0 force-response-1.0
> 7. If I send a HTTP/1.1 request from a machine which is inside the
> transparent proxys realm, it is downgraded to a 1.0 request silently
> (at least it appears in the apache logs as a 1.0 request). This leads
> me to think that some combination of squid running on RH6.2 as a
> transparent proxy is somehow misrepresenting a HTTP 1.1 request from
> MSIE and possibly causing some data to be malformed upon return which
> throws MSIE into some sort of infinate loop.
> If anyone can help with some pointers or advice it would be greatly
> appreciated.
> Thanks in advance,
> Stuart
> --
> ********************************
> Stuart Parker
> Web Objectives
> ********************************
> --
> To unsubscribe, see
To unsubscribe, see
Received on Mon Mar 05 2001 - 00:48:32 MST

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:58:31 MST