[squid-users] select loop fails in QNX6.1

From: Swaroop K <tantrik_porter@dont-contact.us>
Date: Fri, 2 Nov 2001 21:29:41 -0800 (PST)


I am trying to get squid working on a QNX 6.1 box.
I had it working on a QNX6.0 box.

Now, I have compiled squid. When I try to run it,
I run into a problem.
I have also used squid -z to create swap directories.
I am using squid-2.4
The cache.log file gets bloated in size.
The cache.log file gets filled with such messages.

   WARNING: FD <number> has handles, but it is invalid
   FD <number> is a None called ''
   tmout:0 read:0 write:0

here <number> ranges till 999.
Then I see this message at the end:

   Select loop Error, Retry 10

   FATAL:Select loop failed!

I have seen that the problem is with comm_select()
function in the comm_select.c file. The select call
fails! It fails for all file descriptors. squid was
working perfectly on QNX6.0. Can anybody help me with
this? Is there anything that I can do to get it
on QNX6.1?

One more thing,during configuration, I run into a
small non fatal problem. My host system type is not
recognized by config.guess, so I supply my own host
type as x86-qnx-neutrino which configure says is
unknown. But this was the case even with QNX6.0 and it
worked fine.
Please help!

Thanks in advance.

Swaroop K

Do You Yahoo!?
Find a job, post your resume.
Received on Fri Nov 02 2001 - 22:29:43 MST

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 17:03:52 MST