[squid-users] Unable to apply patch - squid 2.4s3

From: John Horne <J.Horne@dont-contact.us>
Date: Thu, 14 Feb 2002 12:35:45 -0000 (GMT)


I've been trying to apply the SNMP patch
(squid-2.4.STABLE3-SNMP_memory_leaks.patch) to a redhat 7.2 cache. I applied
the patch and it reported that it had patched the 3 files with no problems.
Ran configure, and then 'make'. I got:

  gcc -g -O2 -Wall -D_REENTRANT -I. -I../include -I../include -c
  -o snmp_core.o snmp_core.c
  snmp_core.c: In function `snmpDecodePacket':
  snmp_core.c:528: wrong type argument to unary plus
  make[2]: *** [snmp_core.o] Error 1
  make[2]: Leaving directory `/tmp/squid-2.4.STABLE3/src'
  make[1]: *** [all] Error 2
  make[1]: Leaving directory `/tmp/squid-2.4.STABLE3/src'
  make: *** [all] Error 1

I tried it with gcc3 (a wild guess there!), but that made no difference
(same error).

Anyone else have this problem?



John Horne, University of Plymouth, UK Tel: +44 (0)1752 233914
E-mail: jhorne@plymouth.ac.uk
PGP key available from public key servers
Received on Thu Feb 14 2002 - 05:35:47 MST

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 17:06:22 MST