Re: [squid-users] Squid in accelerator mode

From: <>
Date: Tue, 26 Feb 2002 11:21:23 +0000

(See attached file: squid.conf)

I am trying to link to my accelerated site
When I link to its address I want to view the cached one through squid
How do I do that
All I get is access_denied when I go to port 80 on the squid servers


Stelios Issaias
Lead Developer

Amaze Ltd
Tel: +44 (0)207 332 5620
Fax: +44 (0)207 248 4082


                    "Squid Support
                    (Henrik To: "Jack" <>, "Squid Users"
                    Nordstrom)" <>
                    <hno@marasyste cc:
          > Subject: Re: [squid-users] Squid in accelerator mode

According to your config file you are trying to do IP based virtual
hosting but haven't specified a redirector that can map the virtual
IP addresses to the site names so Squid won't know where to send the

Probably you do not really want to do IP based virtual hosting but
name based virtual hosting.

Recommended changes:

  httpd_accel_host virtual
  httpd_accel_uses_host_header on
  This is the proper setup for name based virtual hosting

  http_access allow all
  acl my_servers dst ip.of.your.server1 ip.of.your.server2 ...
  acl HTTP protocol HTTP
  acl port80 port 80
  http_access allow HTTP port80 my_servers
  http_access deny all
  You need to have good access controls, or else your proxy will be
wide open to the world for any use, not only to access your servers.

Henrik Nordström

On Tuesday 26 February 2002 07:06, Jack wrote:
> Hello All,
> I was not able to run squid in accelerator mode for multiple
> server. I configured private DNS for servers.
> When i browse i get Access denied page in browser and 403 error in
> access.log
> I have attached squid.conf file also.
> Thanks
> Jack

MARA Systems AB, Giving you basic free Squid support
Customized solutions, packaged solutions and priority support
available on request

Received on Tue Feb 26 2002 - 04:24:50 MST

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 17:06:32 MST