RE: [squid-users] Change squid binary in flight

From: Lluis Ribes <>
Date: Thu, 27 Nov 2008 14:07:22 +0100


I've finally resolve my problem. I compiled the version 3 STABLE10 with
--with-filedescriptors=8192 and --prefix=/opt/squid. After this, I shutdown
down Squid, I ran "make install" and squid was installed in the same Debian
default location (/opt/squid/), but only the binary: my config file doesn't
change it :)

The last step wasn't configure max_filedescriptors parameter in squid.conf,
because this parameter doesn't work, I don't know why... the last step was
to write the line "ulimit -n 8192" in the startup script
(/etc/init.d/squid), at the beginning.

I started squid (/etc/init.d/squid) and now I'm running with 8192 file

Thanks all for your help!

Lluís Ribes

-----Mensaje original-----
De: Amos Jeffries []
Enviado el: viernes, 21 de noviembre de 2008 4:19
Para: Kinkie
CC: Lluis Ribes;
Asunto: Re: [squid-users] Change squid binary in flight

> On Thu, Nov 20, 2008 at 7:10 PM, Lluis Ribes <> wrote:
>> Dear Squid Folks,
>> I have a Squid 3.0Stable1 running in a server. This version was
>> installed
>> with apt-get Debian package utility. So, it has worked fine until now,
>> where
>> I have file descriptor problems.
>> I saw that my installation has 1024 files as max_filedescriptor, I think
>> not
>> much. I want to change it, but the parameter max_filedescriptor in
>> squid.conf doesn't work (I receive an error message about unknown
>> parameter).
> Are you sure? It may be a runtime limitation; please check that
> there's a 'ulimit -n 8192' line in the squid startup script (replace
> 8192 with your desired limit).
>> So, I think thah the only way is recompile with file_descriptor flag:
>> ./configure --with-filedescriptors=8192 --prefix=/opt/squid
>> --with-openssl
>> --enable-ssl --disable-internal-dns --enable-async-io
>> --enable-storeio=ufs,diskd
>> Ok, I compiled Squid 3.0Stable10. So my question is:
>> Could I replace directly the binary that it was generated by my
>> compilation
>> process and located in $SQUID_SOURCE/src/squid with my debian binary
>> version
>> that it's running nowadays? I have to avoid lost of service of my web.
> the debian package may have different configure options; if you miss
> some configuration option your configuration file may be incompatible
> with your new binary.
> you may want to run 'squid -v' to check that your new configure
> options are compatible with the previous ones.
> You may also want to keep your old binary around, to be able to roll
> back in case of problems.

Indeed. There is at least one patch needed to make squid log correctly in
Debian. (Debian

IIRC the packages are built with 4096 fd by default, maybe stable1 missed
out for some reason. stable8 is available for Debian, please try that
before going to a custom build.

If you must, using the exact same configure options as your packaged build
and the logs/log patch leaves "make install" placing all binaries in the
correct places for a /etc/init.d/restart to work.

Received on Thu Nov 27 2008 - 13:09:43 MST

This archive was generated by hypermail 2.2.0 : Fri Nov 28 2008 - 12:00:04 MST