[squid-users] (0) Success but FATAL: failed to find or read error text file

From: Andre Iskandar <andre_i2000_at_yahoo.com>
Date: Fri, 22 Jan 2010 18:23:34 +0800 (SGT)

I compile squid 2.7 stable7 using this command:
CHOST="i686-pc-linux-gnu" CFLAGS="-O3 -pipe -fomit-frame-pointer -funroll-loops -ffast-math -fno-exceptions -fforce-addr -malign-double" ./configure --enable-gnuregex --enable-async-io=60 --with-aufs-threads=60 --with-pthreads --with-aio --with-dl --enable-storeio=ufs,aufs,coss,diskd,null --enable-removal-policies=lru,heap --disable-ident-lookups --enable-delay-pools --enable-kill-parent-hack --disable-wccp --disable-wccpv2 --enable-snmp --enable-cache-digests --enable-linux-netfilter --enable-ssl --enable-htcp --disable-poll --enable-epoll --enable-http-violations --disable-internal-dns --with-maxfd=65536 --enable-icmp --enable-unlinkd --enable-follow-x-forwarded-for --with-large-files --with-openssl --enable-useragent-log --enable-err-languages=English --enable-default-err-language=English

It runs smooth, no warning, no error and successfull through make and make install.
But when I run this:
rFATAL: failed to find or read error text file.
2010/01/22 17:12:54| Starting Squid Cache version 2.7.STABLE7-20100122 for i686-pc-linux-gnu...
2010/01/22 17:12:54| Process ID 26103
2010/01/22 17:12:54| With 1024 file descriptors available
2010/01/22 17:12:54| Using epoll for the IO loop
2010/01/22 17:12:54| Performing DNS Tests...
2010/01/22 17:12:54| Successful DNS name lookup tests...
2010/01/22 17:12:54| helperOpenServers: Starting 5 'dnsserver' processes
2010/01/22 17:12:54| User-Agent logging is disabled.
2010/01/22 17:12:54| errorTryLoadText: failed to fully read: '/usr/local/squid/share/errors/English/ERR_READ_TIMEOUT': (0) Success
2010/01/22 17:12:54| errorTryLoadText: '/usr/local/squid/etc/errors/ERR_READ_TIMEOUT': (2) No such file or directory
FATAL: failed to find or read error text file.

I tried to :
1. make '/usr/local/squid/etc/errors/' soft linked to /usr/local/squid/etc/errors/'
2. also tried to make '/usr/local/squid/etc/errors/' directory and copy the files from /usr/local/squid/share/errors/English/.

But it didnt solve the problem. Just change '(2) .......' to '(0) Success' with the same FATAL error.

Please help.

Andre Bersenang-senang di Yahoo! Messenger dengan semua teman. Tambahkan mereka dari email atau jaringan sosial Anda sekarang! http://id.messenger.yahoo.com/invite/
Received on Fri Jan 22 2010 - 10:23:44 MST

This archive was generated by hypermail 2.2.0 : Sat Jan 23 2010 - 12:00:05 MST