[squid-users] ZSR and Connection Reset on www.dteenergy.com

From: Ryan Bunce <RBunce_at_micatholicconference.org>
Date: Mon, 8 Aug 2011 16:17:25 -0400


Many thanks to all of you who support Squid, it has served us well for
many years.

I am having trouble getting to the website www.dteenergy.com (a mid-west
based utility company) through Squid. It works fine without.

I have worked about every angle I can. TCPDump shows a few packets and
then a reset packet coming from the web server and then it loops until the
retry count is hit at which point Squid returns a Zero Sized Reply or just
gives a connection error.

I have tried it with multiple Squid versions (2.4-2.7) under various
connection scenarios, behind a filtering firewall and directly connected
with no firewalling save a basic NAT. Also tried from multiple sources,
cable modem, 3G hotspot, and the corporate T3 with the same result.

I was hoping to verify that indeed it is a Squid-wide issue and hoping
that someone could spot something that I'm just not seeing.

Ryan Bunce
Michigan Catholic Conference
Lansing, MI
Received on Mon Aug 08 2011 - 20:17:28 MDT

This archive was generated by hypermail 2.2.0 : Tue Aug 09 2011 - 12:00:01 MDT