Re: [squid-users] Unable to access IIS site through squid3

From: Fredrik Eriksson <>
Date: Thu, 01 Dec 2011 16:23:15 +0100

On 12/01/2011 01:13 PM, Amos Jeffries wrote:
> Ah sorry. In short I think its a kernel bug in the TCP / IP support.

This seems to be a rather persistant kernel bug, if so.

Since there are FD leaks in the debian stable (squeeze/6.0) packaged
version of squid3 (3.1.6-1.2+squeeze1), we pull the squid3 package from
testing (wheezy/7.0). Therefore the testing repo is already added to
our squid servers, so I installed linux from testing as well (linux

I tried both with IPv6 enabled and disabled, which you do by adding
this line to /etc/sysctl.d/disableipv6.conf


neither case worked. Are the kernel developers aware of this bug you
mention, and is it solved in a even later version of linux?

> I hate to say this, but if all else fails you will probably need to
> --disable-ipv6 in Squid to get back to the IPv4-ony behaviour Squid-2
> had. That wont exactly solve the problem, but should avoid it.

This is something we would rather not have to do because of a single
site (out of several thousand requests per minute from our users)
supposedly triggering a kernel bug, even though this is an important
site for our sales department, our environment is hard to maintain as
it is. We'd rather stick to the, by the debian project, pre packaged
software as far as we can.

Can I provide you with any other information, not yet given?


Received on Thu Dec 01 2011 - 15:23:22 MST

This archive was generated by hypermail 2.2.0 : Fri Dec 02 2011 - 12:00:01 MST