Re: [squid-users] config help on squid-3.1.8 on Tomato router

From: Amos Jeffries <>
Date: Tue, 13 Dec 2011 17:42:07 +1300

On 9/12/2011 2:32 p.m., Jason Ianacone wrote:
> I totally agree. Just hoping someone could say what exactly.

Without having provided any info on what those config files contain...

> Problem #2 had to do with the hosts name redirecting the device name to the ipv4 and ipv6 addresses. I have a unique name to the ipv4 and the problem went away.

Then I was sort-of correct. One of the configs is blocking the IPv6
subnets on your LAN.

This could be the Squid config if you have not added in the LAN or
localhost IPv6 details. Or it could be the IPv6 firewall is still at
some default closed settings.


> Sent from my iPhone
> On Dec 8, 2011, at 3:41 PM, Amos Jeffries wrote:
>> On 9/12/2011 8:37 a.m., Jason Ianacone wrote:
>>> I am running squid 3.1.8 (non-transparent) on a Tomato based router. I
>>> connect to my router via SSH (PuTTY). In the GUI I have a tunnel setup
>>> to forward port 444 to 3128. I have a couple of small problems that
>>> bother me.
>>> 1. I run a WHS on my LAN. When I am connected to the
>>> SSH and I type in (the WHS) in Firefox, it connects no
>>> problem. When I type in, I get a connection refused
>>> (146) error. I get the same error if I type in my WAN IP as well.
>>> 2. For my SSH tunnel setup, I have 444 forwarded to This
>>> works perfect. If I change it to forward 444 to WNR3500L:3128, which is
>>> my device name, I get an "access denied" error. So I am connecting to
>>> the proxy, but it doesn't like it for some reason.
>>> Any help would be appreciated.
>> This description reads as if you have configured the proxy or firewall to block access via non-LAN IPs.
>> The help you seek is in the config files somewhere.
>> Amos
Received on Tue Dec 13 2011 - 04:42:14 MST

This archive was generated by hypermail 2.2.0 : Tue Dec 13 2011 - 12:00:03 MST