Re: [squid-users] Problem at loading advert with Squid 2.7 & 3.1

From: Amos Jeffries <>
Date: Wed, 28 Dec 2011 14:43:26 +1300

On 28/12/2011 4:02 a.m., feralert wrote:
> The last response Squid got for that URL was cacheable for 24hrs and had no
> content. Squid is now serving that cached response until the 24hr storage
> time expires.
> Force a cache revalidation from the client (press Shift or Ctrl key while
> clicking the refresh/relaod browser button).
> I have tried that and the same happened, this time firefox didnt even
> made the frame petition.

This is sounding more and more like a firefox bug, or something hidden
between your firefox and the Squid proxy. "smart" firewall or web AV

To have the request not even show up in the packets entering Squid shows
its not entirely not a Squid problem.

> What I tried next was to deny squid the caching of the regex
> 'ad-frame' . After applying that, the reply from the server is the
> same except that now I get:
> X-Cache: MISS from coruscant
> X-Cache-Lookup: MISS from coruscant:3128

Then the caching change has worked as intended. The content provided in
MISS responses is what Squid gets from the upstream server.

Received on Wed Dec 28 2011 - 01:43:30 MST

This archive was generated by hypermail 2.2.0 : Wed Dec 28 2011 - 12:00:03 MST