Re: [squid-users] squid compilation problem

From: Amos Jeffries <>
Date: Thu, 09 Aug 2012 22:52:50 +1200

On 09.08.2012 20:04, nipun_mlist Assam wrote:
> Hi All,
> I am facing compilation problem with squid This fails
> because of some changes in openssl header lhash.h (generally installs
> in /usr/icnlude/openssl/lhash.h).
> I used openssl 1.0.0 (OpenSSL 1.0.0-fips) for building squid.
> The lhash.h header has slightly different macros in openssl 1.0.0 and
> openssl 0.9.8. That is failing the build. I believe if we fix these
> macro calls, squid should compile without any problem. Most probably
> there won't be any issue with any other openssl APIs used by squid
> and
> squid hopefully works just fine with openssl 1.0.0 as well.
> My question here is, if anybody fixed the problem already and if
> squid
> works works with openssl 1.0.0 also.

Could you please search your openssl .h files for the *exact* ABI
version number and report back please.
It should look like "#define OPENSSL_VERSION_NUMBER ..."

Received on Thu Aug 09 2012 - 10:52:55 MDT

This archive was generated by hypermail 2.2.0 : Thu Aug 09 2012 - 12:00:03 MDT