[squid-users] Problem with every release since 3.1.16

From: Janåke Rönnblom <jan-ake_at_ronnblom.se>
Date: Mon, 5 Nov 2012 10:12:18 +0100


Im using squid-3.1.16 on Ubuntu 10.04. Since Squid-3.1 is not included in Ubuntu 10.04 i compiled it myself.

I also use squid_kerb_auth for authentication and squid_ldap_group for checking group membership.

I recently tried to upgrade to Ubuntu 12.04 with the included squid-3.1.19 however I cant get this to work with Kerberos. After a lot(!) of trial and error I tried my 3.1.16 which worked.

After that I tried compiling 3.1.18, 3.1.19, 3.1.20 and 3.1.21. Everyone of those crashes either silently or with a

FATAL: Received Segment Violation...dying.


assertion failed: external_acl.cc:841: "ch->auth_user_request"

This is my configure line:

./configure --disable-maintainer-mode --disable-dependency-tracking --disable-silent-rules --enable-inline --enable-async-io=8 --enable-storeio=ufs,aufs,diskd --enable-removal-policies=lru,heap --enable-delay-pools --enable-cache-digest --enable-underscores --enable-icap-client --enable-follow-x-forwarded-for --enable-negotiate-auth-helpers=squid_kerb_auth --enable-external-acl-helpers=ip_user,ldap_group,session,unix_group,wbinfo_group --enable-arp-acl --enable-esi --enable-zph-qos --disable-translation --with-logdir=/var/log/squid3 --with-pidfile=/var/run/squid3.pid --enable-digest-auth-helpers=ldap,password --enable-negotiate-auth-helpers=squid_kerb_auth --enable-external-acl-helpers=ip_user,ldap_group,session,unix_group,wbinfo_group --with-filedescriptors=65536 --with-large-files --with-default-user=proxy --enable-linux-netfilter --enable-ltdl-convenience --build=x86_64-linux-gnu

I ran the same config with every different release of squid and the only one that works is 3.1.16

To me it looks like a problem with the Kerberos authentication.

Any ideas how to resolve this?

Received on Mon Nov 05 2012 - 09:12:27 MST

This archive was generated by hypermail 2.2.0 : Mon Nov 05 2012 - 12:00:02 MST