Re: [squid-users] squid-internal-mgr not found - cannot login to cachemgr

From: brendan kearney <>
Date: Thu, 11 Apr 2013 16:36:34 -0400

according to "man cachemgr.cgi", the default proxy port is assumed if
no port is specified. if i am mistaken, where would be the
appropriate place to configure the port for the cachemgr?

       Configuration examples for many common web servers can be found
in the Squid FAQ wiki.

              The access configuration file defining which Squid
servers may be managed via this cachemgr.cgi program. Each line
specifies a server:port
              followed by an optional description

              The server name may contain shell wildcard characters
such as *, [] etc. A quick selection dropdown menu is automatically
constructed from
              the simple server names.

              Specifying :port is optional. If not specified then the
default proxy port is assumed. :* or :any matches any port on the
target server.

On Thu, Apr 11, 2013 at 4:41 AM, Kinkie <> wrote:
> On Thu, Apr 11, 2013 at 2:28 AM, brendan kearney <> wrote:
>> resending because i got a mailer-daemon failure for HTML formatting...
>> all,
>> i am running squid 3.2.5 on fedora 16 64 bit on two separate boxes,
>> load balanced with HA Proxy. i am trying to access cachemgr on either
>> one of the squid instances, and both exhibit the behaviour where the
>> squid-internal-mgr URI is not found. attempts to login via the HA
>> Proxy VIP as well as with no proxy configured (direct access) have
>> been tried. both ways produce the same error. below is some header
>> info:
> [...]
>> # -----------------------------------------------------------------------------
>> # TAG: http_port
>> http_port
> [...]
>> can anyone tell my why i am not able to get logged into the cachemgr?
>> the page presents, but the login fails. cachemgr.conf has the IP of
>> both proxies listed, and /etc/httpd/conf.d/squid.conf has the right
>> access allowed by network. /usr/lib64/squid/cachemgr.cgi is chmod'd
>> 755 (rwxr-xr-x) and is chown'd root:root.
> Hi Brendan,
> the reason is that Squid is listening on port 3128, you're connecting
> to the Apache server listening on port 80.
> --
> /kinkie
Received on Thu Apr 11 2013 - 20:36:42 MDT

This archive was generated by hypermail 2.2.0 : Fri Apr 12 2013 - 12:00:05 MDT