[squid-users] Squid 3.2.10 not compilable under OpenBSD 5.2 (updated to3.3.4)

From: Loc Blot <loic.blot_at_unix-experience.fr>
Date: Tue, 30 Apr 2013 13:59:39 +0200

Hi,
i've upgraded from 3.2.10 to 3.3.4. Same problem appears on includes
which are in /usr/local/includes

Also i have another problem, sometimes squid uses 100%CPU and keep at
this state indefinitely, i must kill squid process and restart it. This
problem appears since 3.2.10 (this problem wasn't present un 3.2.9)

-- 
Best regards, 
Loïc BLOT, Engineering
UNIX Systems, Security and Networks
http://www.unix-experience.fr
Le lundi 29 avril 2013 à 10:35 +0200, Loïc Blot a écrit :
> Precision:
> same problem on 3.3.4 version.
> 
> My configure command is ./configure '--enable-pf-transparent'
> '--enable-follow-x-forwarded-for' '--with-large-files' '--enable-ssl'
> '--disable-ipv6' '--enable-esi' '--enable-kill-parent-hack'
> '--disable-snmp' '--with-pthreads' '--enable-ltdl-convenience'
> --enable-auth-basic=""
> 
> And my sasl.h is here under OpenBSD:
> 
> root_at_squid> ls /usr/local/include/sasl/
> hmac-md5.h   md5.h        md5global.h  prop.h       sasl.h
> saslplug.h   saslutil.h
> 
> More, the LDAP helper doesn't use /usr/local/include/ldap.h header
> 
> Making all in LDAP
> g++ -DHAVE_CONFIG_H  -I../../.. -I../../../include -I../../../lib
> -I../../../src -I../../../include    -I../../../libltdl    -Wall
> -Wpointer-arith -Wwrite-strings -Wcomments -Werror -pipe -D_REENTRANT
> -D_FILE_OFFSET_BITS=64 -g -O2 -MT basic_ldap_auth.o -MD -MP
> -MF .deps/basic_ldap_auth.Tpo -c -o basic_ldap_auth.o basic_ldap_auth.cc
> basic_ldap_auth.cc:125:18: error: lber.h: No such file or directory
> basic_ldap_auth.cc:126:18: error: ldap.h: No such file or directory
> 
> Moreover, squid compile doesn't look at /usr/local/lib
> and /usr/local/libexec directories
> -- 
> Best regards, 
> 
> Loïc BLOT, Engineering
> UNIX Systems, Security and Networks
> http://www.unix-experience.fr
> 
> 
> Le lundi 29 avril 2013 à 07:16 +0200, Loïc BLOT a écrit :
> > Hello amos,
> > The command Line you give didn't work. It always tries to compile all helpers. I must disable compile in the makefile and disable Sasl check in the configure file.
> > 
> > Loic Blot
> > 
> > Le 29 avr. 2013 à 03:11, Amos Jeffries <squid3_at_treenet.co.nz> a écrit :
> > 
> > > On 29/04/2013 5:50 a.m., Loïc BLOT wrote:
> > >> Hi,
> > >> i cannot upgrade squid because my ./configure fails (cause : sasl)
> > >> 
> > >> checking sasl/sasl.h usability... no
> > >> checking sasl/sasl.h presence... no
> > >> checking for sasl/sasl.h... no
> > >> checking sasl.h usability... no
> > >> checking sasl.h presence... no
> > >> checking for sasl.h... no
> > >> checking for sasl_errstring in -lsasl2... no
> > >> checking for sasl_errstring in -lsasl... no
> > >> configure: error: Neither SASL nor SASL2 found
> > >> 
> > >> With squid 3.2.9 i haven't this problem
> > >> 
> > >> cyrus-sasl is installed but i don't need SASL.
> > >> 
> > >> Have you got an idea ?
> > > 
> > > We merged in the patch used by OpenBSD ports for auto-detecting SASL and LDAP libraries presence in this release. So a bunch of helpers which use SASL are now attempting build when they did not earlier. But that means the configure *did* detect SASL existence at some point.
> > > 
> > > The helpers using SASL are mostly Basic auth helpers. So if you build with --enable-auth-basic=""  (exactly that, empty string parameter) it should enable basic auth without building any of the helpers. Or you can explicitly list just the ones you want to use.
> > > 
> > > 
> > > To help me resolve the issue permanently could you please let me know what was the exact full ./configure command you used was? and can you also supply a list of the SASL header files you have installed with full paths?
> > > 
> > > Amos
> 
Received on Tue Apr 30 2013 - 11:59:30 MDT

This archive was generated by hypermail 2.2.0 : Tue Apr 30 2013 - 12:00:07 MDT