RE: [squid-users] Squid 3.4.6 is not caching anything

From: <>
Date: Tue, 1 Jul 2014 17:40:52 +1200


Sadly I have deleted my access.log files - and have rolled back to Squid
3.1, and caching is working perfectly. I still need to upgrade to Squid
3.4.6 sometime soon for the sslbump feature. I tried with the
site with the Squid 3.4.6, and nothing is cached. I am going to try and set
up a testing Squid 3.4.6 server this weekend and will reply to this message
if I am still having problems with caching.

-----Original Message-----
From: Eliezer Croitoru []
Sent: Monday, 30 June 2014 2:16 p.m.
Subject: Re: [squid-users] Squid 3.4.6 is not caching anything

Hey Liam,

If you can run a test on the access.log it would supply a bit more
information without intruding to the url level:
cat access.log |awk '{print $4}'|sort|uniq -c

The result will be a tiny statistics about the "character" of your usage.
Since browsers tends to cache content them-self sometimes that cache is
giving you something you cannot just see by looking for a "HIT" in this form
or another.

I remember that most squid analytical tools are testing for "HIT"
objects ignoring all other sides of the cache.
If you have tried djmaza as I suggested and you have not seen a single HIT
when surfing it there is indeed something strange.
I myself use squid 3.4.5 and I do see that there is not HIGH rate of HITs
but I do understand why it can happens and sometimes even understand why it

Once you will have the results of the access.log parsing we will be smarter.


On 06/30/2014 05:05 AM, wrote:
> I have tried deleting the cache and setting its size to 10GB. I ran
> squid -z again and it created the directories before squid -z froze.
> The maximum object size is set to 5GB, and I have checked some sites
> using to see if the can be cached or not. It says that they
> can, and I have had the squid proxy running for about 48 hrs now with
> about 50 clients connected. I have scanned the access.log and there is
> not a single hit. Even if the same page is requested many times.
> Are there some settings that I am missing in squid.conf that is
> stopping the cache from working? Do you know where I can obtain a
> already compiled x86 package for Debian 7 with --enable-ssl and
> Thanks for your help so far.
Received on Tue Jul 01 2014 - 05:41:11 MDT

This archive was generated by hypermail 2.2.0 : Tue Jul 01 2014 - 12:00:05 MDT