RE: cbdata

From: Chemolli Francesco (USI) <>
Date: Thu, 12 Jul 2001 18:12:09 +0200

> > Please see the revised API on
> >
> > Need some help in determining the best API function names.
> The current
> > names are not very consistent, and not sure they actually
> make sense to
> > english speaking people...
> How about:
> cbdataCreate/Destroy
> cbdataUse/Abandon
> cbdataValid

I suggest we mutuate an habit from lisp, which is to use a suffix to
whether a function is a test-function or not. In our case, I'd rename
cbdataValid to cbdataValidp (p is for predicate).

> I doubt cbdataReferenceDone() is needed. Can cbdataAbandon() have the
> same functionality?

Can we attach hooks to events on the object (i.e. a callback to be invoked
the object gets distructed?).
Also, it could be nice extending the callback system so that multiple
can be assigned to a single hook. It would probably decrease performance,
but it could
be a good help in improving modularization.

Received on Thu Jul 12 2001 - 10:04:29 MDT

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:14:06 MST