cachemgr.cgi won't work from remote host

From: Adrian Havill <>
Date: Fri, 11 Oct 1996 21:44:29 +0900

We are trying to use cachemgr.cgi from our server at
<> to access our proxy running on a
sun4m at <>.

I followed the instructions at <>
and tried various combinations of the recommendations in there,
HUPing and re-HUPing. I even suspected it might not be re-loading the
conf file and I tried TERMing it and restarting it.

Currently, the acl portion of squid.conf looks like this:

acl mywwwserver src

acl SSL_ports port 443 563

# Only allow access to the cache manager functions from the local host.
http_access deny manager !localhost !mywwwserver
http_access deny CONNECT !SSL_ports

# Allow everything else
http_access allow all

whenever I try to access the proxy from our web server using the cgi
script, it complains:

dated Fri Oct 11 21:32:54 1996
ERROR:HTTP/1.0 403 Cache Access Denied
Content-type: text/html
Access Denied
Sorry, you are not currently allowed to request
From this cache. Please check with the cache administrator if you
believe this is incorrect.
Generated by squid/
Generated Friday, 11-Oct-96 12:32:54 GMT, by cachemgr.cgi/

I have also tried logging in manually from the sun4m machine and
telnetting into 8088 and entering the command manually. No go.

Any ideas about what I'm missing?

BTW, I was not successful in using the FAQ advice about changing the
default proxy and port by changing:

    HOST_OPT = # -DCACHEMGR_HOSTNAME="getfullhostname()"

to change the default, I resorted to hard-coding the hostname in
cachemgr.c where the appropriate #defines where. Horrible style,
I know. :)

Adrian Havill <>    MAIN: +81 (06) 536-6731
S.E., System Planning & Production Division   FAX:  +81 (06) 536-6741
Received on Fri Oct 11 1996 - 05:41:14 MDT

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:33:16 MST