? Squid not send Http POST command to parent cache

From: Wu Shangguang <wsg@dont-contact.us>
Date: Thu, 24 Apr 1997 09:05:54 +0900 (CDT)

Dear Sir/Madam,

I have built the package of squid 1.1.9 on Solaris 2.4(Sun SPARC), and now I
tried to set up hierarchical structure between two squid cache proxy.

The problem is: the subordinate cache do not send Http POST command to
parent cache, while GET command(even with cgi-bin or ?) is ok.

From the log file of subordinate cache, the following line is said:
861838173.241 103074 TCP_MISS/000 0 POST
http://www6.zdnet.com/cgi -bin/texis/swlib/hotfiles/search.html -
DIRECT/www6.zdnet.com -

That confirms that the subordinate cache process the POST command locally!

On the subordinate cache, the squid.conf file contains the following line:
cache_host parent 7086 7088 proxy-only default
neighbor_timeout 6
#hierarchy_stoplist cgi-bin ?
cache_stoplist cgi-bin ?


Following the comments within squid.conf, I have tried the entries below,
but all failed:
cache_host ... weight=250
single_parent_bypass on

Hope for your reply eagerly!

Best regards,
Wu Shangguang

Wu Shangguang
CSCW Research Group | E-mail: wsg@csnet4.cs.tsinghua.edu.cn
Dept of Computer Sci & Tech |
Tsinghua Univ, 100084 |
Beijing, PR China |
Received on Wed Apr 23 1997 - 18:30:52 MDT

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:35:02 MST