Re: Cant load squid 1.1.19 on boot

From: Duncan Anker <>
Date: Sun, 27 Apr 1997 17:49:17 PDT

>This may seem like a stupid question but im at a bit of a loss.
>I am using Redhat linux 4.1 with kernal 2.0.29 and ive setup Squid 1.1.19
>which works excellently all together, but i cant get squid to load on boot
>This is whats output to the /var/log/squid/cache.log:


>Permission denied
>FATAL: storeStartRebuildFromDisk: Can't open tmp swaplog
>Squid Cache (Version 1.1.9): Terminated abnormally.

So it seems to be a permissions problem.

>if i try and load squid in the /etc/rc.d/rc.local with:
>if [ -f /usr/local/squid/bin/squid ]
> echo "Starting Squid proxy_cache"
> /usr/local/squid/bin/squid &
>I dont know why, squid is in its normal location of /usr/local/squid/bin/
>and works brilliant once the system is booted up and i execute squid with
>'squid &' eg from the cache.log:


>Can someone please explain to me whats going on? Everything else loads
>from the rc.local with no problems except squid. Ive even tried setting it
>suid root with no luck. Ive also tried to make it look for the squid.conf
>file from the command line in the rc.local and that doesnt work either.

Later versions of squid won't run as root, and change user ID once
they have started up. I suspect the problem may be ownership of
your squid files. Who owns the processes at startup time under
Redhat? It would work fine when you start it as root because root
has access to all files.

As a quick fix, check the conf file to see who squid runs as, and
change ownership on all of the files. e.g if it runs as "nobody":

chown -R nobody /where/I/put/squid/

Hope this helps

Get Your *Web-Based* Free Email at
Received on Sun Apr 27 1997 - 18:16:38 MDT

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:35:03 MST