Squid and local multicast network

From: Simon Rainey <srainey@dont-contact.us>
Date: Wed, 27 Aug 1997 14:41:32 +0100

I have 7 Squid caches running under BSDI 2.10 and all on the same IP
subnet. I wish to configure them as siblings and it seems reasonable to set
up a local multicast network. However, after a couple of hours surfing the
web I'm not much nearer being able to set this up.

Multicast support is built into the kernel, but do I need to use mrouted if
I'm not routing traffic beyond my local subnet? Can I choose any address
from the block given that I'm not routing this network, or is
there a block for private multicast networks (is that what is

I've tried setting up rm-ps-squid-multicast.rmplc.co.uk to be and
then using this in squid.conf (on the host rooster) ...


cache_host rm-ps-squid-multicast.rmplc.co.uk multicast 8080 3130 ttl=64
cache_host adder.rmplc.co.uk sibling 8080 3130 multicast-responder
cache_host rattle.rmplc.co.uk sibling 8080 3130 multicast-responder
cache_host barracuda.rmplc.co.uk sibling 8080 3130 multicast-responder
cache_host elk.rmplc.co.uk sibling 8080 3130 multicast-responder
cache_host whale.rmplc.co.uk sibling 8080 3130 multicast-responder
cache_host eagle.rmplc.co.uk sibling 8080 3130 multicast-responder

I've also added a route ....

route add -net -netmask -interface

where is the IP address of the single ethernet port in the

I've also tried using with no luck.

If I ping I get responses from all the other hosts, but Squid
just doesn't seem to be responding to multicast requests.

I realise this is slightly off topic, but any advice would be gratefully


Simon Rainey Direct Line: 01235 823238
Principal Internet Development Engineer Fax: 01235 823424
RM Internet for Learning E-mail: srainey@rmplc.net
New Mill House, 183 Milton Park, Abingdon, Oxfordshire, OX14 4SE, England
Received on Wed Aug 27 1997 - 06:51:10 MDT

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:36:51 MST