Re: MALLOC Problems

From: Bill Wichers <>
Date: Wed, 7 Jan 1998 23:54:28 -0500 (EST)

You're running *5* seperate Squids on each machine?!? Wow! Unless you're
doing some specific stuff, you might be better off running one massive
Squid process on each machine instead of your current 5 smaller processes.

You might be running into file descriptor problems with that many squid as
well. I don't know how many filedescriptors IRIX will give each process,
but you might be at or near the limit, so that's something to check.

Aside from that, the memory problems and malloc troubles that squid has
are well known. That aren't any definate fixes that I know of, only a
bunch of workarounds. Compiling Squid using the GNU libmalloc seems to
work best for most users, so if that didn't help you then there probably
isn't much more you can do by just swapping malloc libraries. I'd try
using just one Squid instance per machine and see if that helps.


On Thu, 8 Jan 1998, Cesar Cancio wrote:

> Hello,
> I am hoping that someone can enlighten me with their own experience with
> SQUID MALLOC problems.
> I work for a medium size ISP with around 40,000 active users.
> I administer a pair of very "BUSY" SGI Origen 200's with running IRIX 6.4.
> With 2x180 MHZ IP27 Processors;Main memory size: 768 Mbytes;
> They run 5 x Squid-1.1.18 instances on each server and they load balance
> and service HTTP and FTP request between them via Round-Robin routine.
> Each Squid Instance has a cache size of 4 Gb. so a total of 20 Gb's of hard
> disk space on each Squid Server. Swap size reported by "sar" is 255616.
> My big problem is memory leaks which deteriorate server performance
> dramatically. I initially tried it with Squid 1.1.15 with the SGI MAllOC
> routines, but that only lasted 3 or 4 days before the server started losing
> all system memory and then all swap space down to "zero". The server load
> average would shoot staright UP and after an hour without human
> intervention the server would kill one of the squid instances itself and
> free up some swap space and system memory but not all.
> I then recompiled Squid 1.1.15 with the GNU Malloc routines and tried it
> out, but unfortunately I ended up the same problems with memory leaks. I
> tried using the recommended "DLMalloc" routine, but that proved worse that
> compiling with the GNU Malloc routines.
> I am now about to try SQUID 1.1.19 with the GNU Malloc routine but I'm
> really not all that confident that this will work as well.
> Can anyone out there offer advise???
> Thanking you all in Advance!
> Cesar
Received on Wed Jan 07 1998 - 20:57:18 MST

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:38:20 MST