MALLOC Problems

From: Cesar Cancio <>
Date: Thu, 08 Jan 1998 14:13:04 +1300


I am hoping that someone can enlighten me with their own experience with
SQUID MALLOC problems.

I work for a medium size ISP with around 40,000 active users.

I administer a pair of very "BUSY" SGI Origen 200's with running IRIX 6.4.
With 2x180 MHZ IP27 Processors;Main memory size: 768 Mbytes;
They run 5 x Squid-1.1.18 instances on each server and they load balance
and service HTTP and FTP request between them via Round-Robin routine.

Each Squid Instance has a cache size of 4 Gb. so a total of 20 Gb's of hard
disk space on each Squid Server. Swap size reported by "sar" is 255616.

My big problem is memory leaks which deteriorate server performance
dramatically. I initially tried it with Squid 1.1.15 with the SGI MAllOC
routines, but that only lasted 3 or 4 days before the server started losing
all system memory and then all swap space down to "zero". The server load
average would shoot staright UP and after an hour without human
intervention the server would kill one of the squid instances itself and
free up some swap space and system memory but not all.

I then recompiled Squid 1.1.15 with the GNU Malloc routines and tried it
out, but unfortunately I ended up the same problems with memory leaks. I
tried using the recommended "DLMalloc" routine, but that proved worse that
compiling with the GNU Malloc routines.

I am now about to try SQUID 1.1.19 with the GNU Malloc routine but I'm
really not all that confident that this will work as well.

Can anyone out there offer advise???

Thanking you all in Advance!

Received on Wed Jan 07 1998 - 17:23:42 MST

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:38:20 MST