Re: SSL, IE3 works, Netscape3/4 doesn't ???

From: Mark Reynolds <>
Date: Sat, 18 Jul 1998 10:35:24


At 15:18 17/07/98 -0600, Duane W. asked:
>What OS is Squid running on?

Sorry, I forgot to mention that. Linux / Redhat 5.1


At 09:13 17/07/98 -0600, Alex Rousskov <> wrote:

>Just FYI, I _can_ get in (to the first form,
>, that is) with
>my "Netscape 3.01S" running on "IRIX Meta-Bug 6.2 03131015 IP22". Squid

>On Fri, 17 Jul 1998, Mark Reynolds wrote:
>> Great. Are you on a private network number, behind a firewall?
>No I am not. The info was primarily for those people out there testing/fixing
>SSL stuff so they would know that it is not [only] a Netscape problem. AFAIK,
>there was some progress made last night with SSL bugs. I hope a better SSL
>code will be released soon.
Thanks Alex,
I'm trying to figure out if there is a bug, and if so, where it might be.
I think you might be on a different problem? When I use squid 1.1 or
1.2 (both on Linux/Redhat 5.1) SSL seems to work OK in IE3, but not
Netscape 3 or 4. I haven't seen any notes or FAQ entries regarding this.

At 13:53 17/07/98 -0500, wrote:

>I had a similar problem with Netscape. I found that if I configured
>Netscape to use the same proxy and the same port for both http and
>https (``Security Proxy'') then it wouldn't work, but if I changed the
>https proxy to go to a different server, or even the same server on an
>alternate port, then it worked fine. Since Squid 1.2 supports
>listening on multiple ports, I just configured my squid to listen on
>two ports and I use one for http and one for https. I think this is a
>bug in Netscape, and I've reported it, but as of 4.5 beta it doesn't
>seem that they've fixed it.

Well, I think you're right. When I set my 'Secure Proxy' to be another
squid server, either 1.1 or 1.2, Netscape 3 works fine to an SSL page.
Set both http and secure proxies to be the same server, and you can't
access ssl pages.

Just tried version 4.03 though, and it doesn't have the same problem.
It seems to work fine here for me.

Since Joe doesn't seem too confident that it is a bug, can anyone else
confirm these observations? Or has this been reported before?

Thanks everyone for your help.


regards, +--------------------------+
            Mark Reynolds | Phone 08 9474 1211 |
+-------------------------------| Fax 08 9474 4772 |
| Reynolds Technology Pty Ltd | Pager 08 9480 5884 |
| 8 Preston Street Como 6152 | |
| PO Box 120 Como 6952 | |
| Western Australia +--------------------------+

PS The following message are auto deleted
 o "It doesn't work, please fix urgently", with no other details.
 o Unsolicited email including jokes, virus warnings, chain letters.
Received on Fri Jul 17 1998 - 19:36:27 MDT

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:41:09 MST