gcc error compiling squid-1.1.22 under Solaris-2.6

From: Jason Haar <Jason.Haar@dont-contact.us>
Date: Sun, 19 Jul 1998 03:58:18 +1200

Hi there

I've been running Squid under Linux for some years now, and this is the
first time I've tried it on Solaris boxes. 1.1.22 compiles fine using
gcc-2.7.2+ under Solaris 2.4 and 2.5, but the first time I tried compiling
it under 2.6, it spat the dummy.

make: Warning: Both makefile' and Makefile' exist
Making all in lib...
gcc -O2 -I../include -I./../include -c safe_inet_addr.c
safe_inet_addr.c:26: warning: struct in_addr' declared inside parameter list
safe_inet_addr.c:26: warning: its scope is only this definition or
safe_inet_addr.c:26: warning: which is probably not what you want.
safe_inet_addr.c: In function safe_inet_addr':
safe_inet_addr.c:30: storage size of A' isn't known
safe_inet_addr.c:44: dereferencing pointer to incomplete type
*** Error code 1
make: Fatal error: Command failed for target safe_inet_addr.o'
Current working directory /tmp/squid-1.1.22/lib
*** Error code 1
make: Fatal error: Command failed for target all'

I've tried this with gcc- and gcc-2.8.1 (both binary pkg releases
from www.sunfreeware.com) - both crash out at the same error.

I've been compiling quite a bit of stuff on this 2.6 compiler fine - it
appears to affect squid only...

Any ideas? Currently I'm using the 2.5 binaries I have - they seem to run
fine under 2.6 - but there were quite a few kernel changes made in 2.6 which
(I assume) a "native" version of squid could make use of(?).

Any ideas?

Jason Haar
Unix/Network Specialist, Trimble NZ
Phone: +64 3 3391 377 Fax: +64 3 3391 417
Received on Sat Jul 18 1998 - 09:05:58 MDT

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:41:10 MST