Re: How to compile Squid in HP-UX

From: Henrik Nordstrom <>
Date: Sun, 19 Jul 1998 03:37:24 +0200

Orlando Feitosa wrote:

> ./configure --prefix=/usr/local/squi
> loading cache ./config.cache
> checking host system type... hppa1.1-hp-hpux10.20
> checking for gcc... (cached) cc

There are a number of ways around this:
1. make realclean
2. rm config.cache

And if that does not help, then you probably does not have gcc in your
PATH (try running gcc -v). If gcc is in your path then it could be the
case that your environment forces configure to use cc.

3. setenv CC gcc

If you have a decent HP ANSI C Compiler then I would recommend that you
use the HP compiler with option -Ae instead of gcc despide the varning
from configure. I have had many code-generation problems with gcc on
HP-PA machines when compiling various applications and it has always
worked when using the HP ANSI-C compiler. I have NOT tried to compile
Squid on a HP-PA machine.

Henrik Nordström
Sparetime Squid Hacker
Received on Sat Jul 18 1998 - 18:41:42 MDT

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:41:10 MST