Re: NEED HELP: Problems with squid and dns...

From: Jon Peatfield <>
Date: Wed, 14 Oct 1998 01:07:02 +0100

> 2. Symptom Compilation, linking and installation with gcc 2.8.1
> - no problem. Starting squid - no problem, no error messages.
> When a browser tried to access a page using squid as proxy,
> squid generated the message "Connection Failed" and mentions
> error "(13) Permission denied". Further investigation showed
> that "dnsserver" always returned "add 0" for
> any host lookup.

This may be unrelated, but there is a problem with gcc (2.8.1 at least) on
Irix 6 which causes it to always return the string for _ANY_
address when calling inet_ntoa(). I tried to track this down and failed. The
calling convention into libc must be different, but as far as I could tell
with gdb gcc and Irix cc were both passing the same set of things on the
stack, but the gcc one always resulted in

We noticed this first with ssh. The version compiled with gcc works but logs
all connections as which is next to useless. We gave up and
used the Irix cc to compile it.

It has been mentioned on the ssh newsgroups several times.

 -- Jon
Received on Tue Oct 13 1998 - 17:55:40 MDT

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:42:29 MST