RE: --enable-async-io code status

From: Jeff Madison <>
Date: Wed, 6 Jan 1999 09:32:15 -0700


I noticed this message this morning and thought a problem that I am having
may be of interest to you. Below is a message that I posted to the list
last night and describes a problem that many who use -enable-async-io are
encountering. I run Solaris 2.6_x86 with all patches. See the message

I have been working with squid for about a year now and it has been great
fun. I have come across an issue that is causing us some serious headaches
at this time. We run 2 what I would call large caches, the systems are Quad
XEON 400, 1GB or RAM, and 54GB Hardware Level RAID Arrays. The problem I am
having is that for speed and load reasons I have compiled
with -enable-async-io. With this option enable Squid appears to "forget" or
loose track of what and how many items it has in it's cache directory. I
saw a message some time back that indicated that if you deleted the swap.*
files in the cache directory that Squid would be forced to rebuild the
swap-state file when it was restarted. This proved to be true. I would
start Squid and it would say it only had approx 60000 objects in the cache
directory, hard to believe when it's using 40 GB of drive space. After
stopping Squid, removing swap.* files from cache directory and restating
Squid it would report that it had over 2 million objects after is was done
rebuilding. The problem is that with this much data squid takes hours to
rebuild and with the load we place it under it chokes and dies before it
ever finishes rebuilding forcing a restart and restarting the rebuild. We
are running Squid 2.0.Patch2. My question is has this bug been fixed and in
what version or does anyone have any suggestions.

Any comments would be appreciated.

Jeff Madison
Systems Engineer
(801)924-0900 x 101

-----Original Message-----
From: David J N Begley []
Sent: Tuesday, January 05, 1999 11:30 PM
To: Squid Users
Subject: Re: --enable-async-io code status

On Mon, 4 Jan 1999, Jens-S. Voeckler wrote:

> On Wed, 30 Dec 1998, David J N Begley wrote:
> >> >Platforms for which it could be considered non-experimental is
> >> >Linux with glibc-2.0.7 and Solaris 2.6?
> >> Probably, I don't know about Solaris.
> >What would you like people to look for in reporting whether or not
> >"enable-async-io" works on Solaris? (FWIW, I'm using this option on
> >Solaris 2.5.1.)
> I wouldn't know the concrete metrics for that, but "it works" (e.g. the

Well, assuming there are no major stumbling blocks I guess it's reasonably
safe to include Solaris 2.5.1 and upwards (in addition to Linux) in the
"non-experimental" list (though with caveats, just as there are against
in the FAQ).

It'd be nice to have some sort of tests/metrics though, so the core Squid
authors could be sure whether or not Squid on Solaris with enable-async-io
worked sufficiently to their satisfaction.

> cache answers fast and reliably) with my local test caches (2.5.1+2.6, low
> load), but "it does not work" (e.g. the cache slowed considerably compared
> to non-aio) when testing on one of my production caches (2.5.1, toplevel
> cache). The latter may be a further indication that my disk subsystem on
> the old caches is not performing as well as I need it to.

Both my boxes are 2.5.1, one handling 188,000+ requests per hour (end users,
peering, child proxies, &c.) and the other handling only 45,000+ requests
hour (some peering, plus the other proxy as a child using cache digests) -
each at opposite ends of our WAN. Both are running with AIO and have
similarly configured cache disk subsystems.

Performance on the two proxies (per cachemgr) is:

Median Service Times (seconds) 5 min 60 min:
        HTTP Requests (All): 0.12106 0.27332
        Cache Misses: 0.68577 0.76407
        Cache Hits: 0.03829 0.04047
        Near Hits: 0.89858 0.94847
        Not-Modified Replies: 0.01847 0.02592
        DNS Lookups: 0.01852 0.01609
        ICP Queries: 0.00687 0.00774

Median Service Times (seconds) 5 min 60 min:
        HTTP Requests (All): 0.15048 0.16775
        Cache Misses: 0.89858 1.05672
        Cache Hits: 0.02742 0.02742
        Near Hits: 0.64968 0.94847
        Not-Modified Replies: 0.00865 0.01469
        DNS Lookups: 0.00669 0.00779
        ICP Queries: 0.00298 0.00298

Unfortunately I haven't run without AIO on 'em (that is, when using Squid
so I have no before/after comparison - but as you said above, "it works".


Received on Wed Jan 06 1999 - 09:26:13 MST

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:43:55 MST