RE: mrtg versus squid (almost there...)

From: Jeff Madison <>
Date: Fri, 15 Jan 1999 13:21:09 -0700

It would appear to me that you have not patched the version of MRTG that you
are using. The patch is for an older version of MRTG than the one currently
available and I didn't want to hack with it so I just downloaded the
from the FAQ. This worked great with my cfg file. The only thing I had to
edit in the that I downloaded was I changed the very first line to
be "#!/usr/local/bin/perl" instead of "#!/usr/local/bin/perl-5.04".

Jeff Madison
Systems Engineer
(801)924-0900 x 101

-----Original Message-----
From: Alexandre Almeida Wanderley []
Sent: Friday, January 15, 1999 12:25 PM
Subject: mrtg versus squid (almost there...)

        Hi, Glenn and Jeff

        Well, I have mixed both of your sugestions. At all, my squid.conf didn't
have the snmp_incoming/outgoing_address entries (I didn' see it at FAQ) and
made a mistake: I put the machine name in the mrtg.conf and in the
file I create the snmp-acl pointing to "localhost". Now, when I run a test
snmpwalk this is the answer:

snmpwalk -p 3401 localhost public .
Name: -> INTEGER:
Name: -> INTEGER: 23968
Name: -> Timeticks:
(8570772) 23:48:27
End of requested OID tree.

        See my running squid.conf (just lines about snmp):

        acl management-station src
        snmp_port 3401
        snmp_mib_path /usr/local/services/squid/etc/mib.txt

        snmp_do_queueing on

        snmp_agent_conf view all .1.3.6 included
        snmp_agent_conf view squid .1.3.6 included
        snmp_agent_conf user squid - all all public
        snmp_agent_conf user all all all all squid
        snmp_agent_conf community public squid squid
        snmp_agent_conf community readwrite all all

        snmp_acl public deny all !management-station
        snmp_acl readwrite deny all


        But... (almost always there is a "but"...)
        When I run mrtg I receive the only one following answer:[2] ./mrtg mrtg.conf
        Unknown SNMP var cacheServerInKb

        Was this snmp variable excluded from squid mib and don't know...?

        Again, thankyou your attention

        Alexandre Almeida
Received on Fri Jan 15 1999 - 13:20:48 MST

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:44:03 MST