Squid Proxy shrinking

From: List Server Account <lists@dont-contact.us>
Date: Tue, 6 Apr 1999 09:44:26 +1200 (NZST)

My squid proxys (2 of them) continually shrink in size.

I am running Linux 2.0.35 on 1, and Linux 2.2.2 on the other. (Last time
I posted this, I neglected to mension this fact, and everyone almost
convinced me that I was running Solaris 2.6 - which is definately not the

"DF" reports I am using only 10% of the inodes
I have plenty of hard drive space free.
In the main drive, I partitioned into 4, and made each partition
2.4 gigs, of which the specified max for squid is 2 gigs. I made
sure that the partitions were formatted with "0%" root only space,
and used 2048 bit inodes, just to be sure.

I have tried 3 different versions of squid, the current one being
2.1 Patch 2, with the leak patch installed.

I have tried flushing the cache, which helps for a short while.

An example squid error is :

1999/04/06 04:57:43| diskHandleWrite: FD 48: disk write error: (28) No
space left on device
1999/04/06 04:57:43| storeSwapOutHandle: SwapOut failure (err code = -6).
1999/04/06 04:57:43| WARNING: Shrinking cache_dir #3 to 1453064 KB

Thanks for any help,

Received on Mon Apr 05 1999 - 15:29:53 MDT

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:45:43 MST