Re: cache_effective_user

From: Ayca Ardic <>
Date: Fri, 9 Apr 1999 12:49:47 +0300 (EEST)

Mr. Nordstrom.
Thanx for reply,

I downloaded this version (squid-2.0-4) from
My kernel is 2.0.X. Do you think that I installed a wrong version ?

By the way, I solved the cache_effective user problem.
But now, I have a different problem.

Everything works fine, when I manually set the proxy settings in my
browser. But when I want to use it as transparent proxy, it doesn't work.
My router settings are right. I checked it. But, unable to see the web
pages. I tried to look at access.log. But, no request appers in

On Thu, 8 Apr 1999, Henrik Nordstrom wrote:

> > I installed squid-2.0-4.
> There is no such version of Squid. This must be a version of a binary
> install package.
> > FATAL: Don't run Squid as root, set 'cache_effective_user'!
> > Squid Cache (Version 2.0.PATCH2): Terminated abnormally.
> If this is on Linux 2.0.X, then make sure the binary is made for Linux
> 2.0.X and not Linux 2.2. Installing a binary made on Linux 2.2 onto a
> Linux 2.0 system won't work.
> --
> Henrik Nordstrom
> Spare time Squid hacker
Received on Fri Apr 09 1999 - 04:05:45 MDT

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:45:46 MST