Re: Squid and Socks

From: Oleg Makarenko <>
Date: Tue, 27 Apr 1999 14:21:37 +0400

That is probably a bug in socks5 client software.
Have you applied patches (especially patch1 from to your socks5 r9?
Without that patch runsocks just coredumps.

You can quickly check it with:
$runsocks telnet somewhere

s5telnet and s5ftp both work even with the bug as they use static library.


Markus Leutwyler wrote:

> Hello,
> I'm using squid 2.2.STABLE2 on either Redhat Linux 5.2 or Suse Linux 6.0
> The machine is behind a SOCKS Firewall
> I tried the following to "socksify" squid:
> downloaded socks support from (socks5-clients package)
> and tried to start squid with "runsocks squid". But this just fills up the swap space
> quickly and i have to kill the process. the same happens with other programs e.g
> "runsocks lynx". Any idea what's going on?
> Note: the s5ftp and s5telnet utilities included in the socks5-client package work without
> problems on the same machine.
> Thanks for any help
> Markus
> Inserto AG, Switzerland
Received on Tue Apr 27 1999 - 04:38:18 MDT

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:45:58 MST